Knowledge Base



KB10902 - Import Excel spreadsheet data into a vector map layer.


Open data from Excel spread sheet as a new points layer.

  1. Ensure that the first two columns of the spreadsheet contain the x and y coordinate values and that the header names for these columns are "X" and "Y" or reflect other supported naming: "Lon", "Longitude", "Easting", "Lat","Latitude", and "Northing". Optional 3D value names are: "Z", "Elevation", and "Level".
  2. In Excel, save data as a CSV (comma separated value) file. The resulting file will have the file name ending *.csv.
  3. In the TatukGIS Editor, use menu File/Open or Layer/Add to open the *.csv file as a layer. The CSV layer will be added to the map window.

If desired, use Editor menu Layer/Export to save the data from the CSV layer to another supported vector layer format (such as a *.shp file).

Import data from an Excel spreadsheet into an existing vector map layer (as attributes).

  1. Use Editor menu Data/Import data to open the Import data dialog box.
  2. Within the Data/Import data dialog, select the subject Excel (*.xls or *.xlsx) file.
  3. Within the Data/Import data dialog box, specify an attribute field in the layer and a column in the spread sheet on which to perform the import operation. (A common method is to import based on record ID number.)

The data from the spreadsheet will be populated (as attributes) into the layer. The layer can be any vector type: points, multi-point, line, polygon.

As of the TatukGIS Editor version 4.16, Excel installation is not required. (Thanks to this, support is for 64 bits as well as 32 bits.)

If either operation must be performed repeatedly, consider writing a script to automate the process. Refer to the TatukGIS Editor's built-in scripting capabilities.

Created: May 28, 2014, Modified: June 04, 2014